.zip and .mp4

Home \ forums/topic \ .zip and .mp4
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #391


    I’ve recently installed the module and was attempting to upload videos in zipped format, but it doesn’t work. I get no error and no upload. Basically nothing happens. Isn’t zip supported??

    MySQL Server: 5.5.24-0ubuntu0.12.04.1

    PHP Version: 5.3.10-1ubuntu3.2

    Joomla Version: 2.5.6

    Michael Gilkes

    @spec. Thanks for posting. Ok, you need to provide some more info for me to really be able to help you. Go to the Module Manager, click on the module and copy and paste the information at the bottom of the module. It should look something like:

    Also, please post what you specify in the “Permitted file types” text area.

    The module does not limit upload at all. You can upload any file, all you need to do is specify the correct mime type.


    Thanks for your response!! 😀 Here is the info, and I’m not sure what the mime parameter would be for zip or mp4? (sorry, i’m not familiar with mime protocol)


    PHP Version: 5.3.10-1ubuntu3.2.

    FILEINFO_MIME_TYPE is defined.

    finfo_open is callable.

    finfo_file is callable.

    finfo_close is callable.

    mime_content_type is callable.

    This is a NON-Windows OS: Linux.

    escapeshellarg is callable.

    exec is callable.

    shell_exec is callable.

    Michael Gilkes

    @spec. Everything looks good. Send me an email (michael[at]valorapps[dot]com) so that we can continue the conversation. I want to have access to the page that has the uploader, so if you can give me temporary admin access to your site, I can have a quick look and investigate what is going on.


    So the problem appears to be with file size. I can indeed upload smaller zip and image files, but I am unable to upload a 250mb zip file or mp4. Below are my php configs showing my size limit (1000M)

    file_uploads = On

    ; Temporary directory for HTTP uploaded files (will use system default if not

    ; specified).

    ; http://php.net/upload-tmp-dir

    ;upload_tmp_dir =

    ; Maximum allowed size for uploaded files.

    ; http://php.net/upload-max-filesize

    upload_max_filesize = 1000M

    ; Maximum number of files that can be uploaded via a single request

    max_file_uploads = 20


    After modifying the following values in php.ini, I am now able to upload large files.

    max_execution_time = 600

    max_input_time = 600

    memory_limit = 1000Mnnn

    post_max_size = 1000M

    upload_max_filesize = 500M

    Now I can’t upload zip files due to error code 4. Something must have broken in the process

    Michael Gilkes

    @spec. Thanks for posting your results. Actually, I think you can tweak your settings to be more efficient. If you want to upload files <= 1GB. You should have the following settings:

    post_max_size should be a little larger than upload_max_filesize to accommodate post data other than the file upload data.

    Michael Gilkes

    @spec. Actually, it is working perfectly. If you look at the screenshot you will see that there are 2 notices, not 1. I only uploaded 1 file, which is the zip file and it says that it was uploaded successfully. The second notice which is an error 4 message occurs because there was no second file uploaded.


Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘.zip and .mp4’ is closed to new replies.