Upload error 500

Home \ forums/topic \ Upload error 500
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #95

    I can’t get it work. Always the error:

    Upload error 500 is comming.

    CMOD is ok.

    Will you help me?


    Kind regards


    Michael Gilkes

    @janvankuijk. Thanks for using my plugin. I see the error 500 when trying to upload. As for how to fix it, I can’t say whether I can help you without you providing more information. For example, I may need to know your Joomla version, PHP version, and either access to your php configuration (phpinfo). If you want to, you can send me the information via email.

    Now, remember that Easy Flash Uploader actually uses SWFUpload and a search on Google will reveal some interesting information which, at least, initially leads me to believe that it is an issue of Flash 10 being incompatible with mod_security. However, at this point, I can’t be certain.

    Hope this helps some.


    i have the same problem, and all the swfupload.com demos work perfectly for me.

    Michael Gilkes

    @ gdpodesta. Thanks for posting. As I mentioned in my post to janvankuijk, you may need to provide some more information to get help for this particular problem. Please provide your Joomla version, PHP version, and access to your php configuration (phpinfo). If you want to, you can send me the information via email.

    Typically, you may be restricted from uploading files of a certain size on your server, or it could be a mod_security setting that is causing the problem. There is a useful discussion about SWFUpload-based uploaders here: http://swfupload.org/forum/generaldiscussion/86

    To solve the Upload Error 500, you need to let me know what size files you are uploading and what setting your PHP has for upload_max_filesize, post_max_size and memory_limit. In addition, it could be a mod_security issue, and it would be good to find out what the error is in your server log. If you can provide this information for me, I may be able to assist you. Depending on your server configuration, you may have to create or alter your .htaccess file to disable mod_security.

    I know that the swfupload demos do not actually upload files, and also it depends on your server’s configuration. Actually, it would be really helpful if you could allow me to access the page that has the uploader so that I could test it. Turning on debugging for the uploader will help as well (see link: http://support.michaelgilkes.com/topic/server-io-error#post-278).


    I also got the Upload error 500 did some diging in logs and found, for what ever reasons, default joomla install had public_html/plugins directory security set for 0777 and I changed it to 0755 and all worked well. Hope this helps someone.


    I am getting the 500 error everytime i try to upload a file. The file is less than 1mb in size, i have verified that i do have write priviliges to the folder i specified in the backend. Here is a snippet from my error log.

    [Tue Apr 10 13:47:27 2012] [warn] [client 172.16.x.x] mod_fcgid: HTTP request length 132532 (so far) exceeds MaxRequestLen (131072), referer: http://eportal.satellitemed.com/index.php/upload-an-image

    The only time i DONT get the 500 error, is when i enable to ability to overwrite, and click yes on the option. Any help would be greatly appreciated!.




    OH My bad, i think i posted in the wrong forum, i am using easy file uploader, NOT easy flash uploader.


    Actually i fixed it like this, in case anyone else has the same problem:

    It can occur when uploading a file that is too large on an Apache web server with mod_fcgid enabled. The solution is to set MaxRequestLen to a larger value.

    Just add this to /etc/apache2/mods-available/fcgid.conf

    # to get around upload errors when uploading images increase the MaxRequestLen size to 15MB

    MaxRequestLen 15728640

Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘Upload error 500’ is closed to new replies.