Can't correctly show Chinese filename

Home \ forums/topic \ Can't correctly show Chinese filename

Support Home Page Forums Joomla Software Easy Folder Listing Module Can't correctly show Chinese filename

This topic contains 1 reply, has 2 voices, and was last updated by  Michael Gilkes 2 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #846

    Flynn
    Blocked

    Hi,

    First thank you for the excellent easy folder listing pro module.

    I have a problem while using it with Chinese filename. Here are some information:

    * Joomla 3.4 and your module run in an Ubuntu system with language set to zh_CN.UTF-8

    * PHP.ini have defalut_charset=”utf8″

    * The files with Chinese name were transferred to the server by flashfxp with UTF-8 encoding.

    * All these files with Chinese name can be correctly shown using “ls” command in the server

    * I use another PHP app named “AutoIndex” which can correctly show all the files with Chinese filename ( http://download.vcasystem.com/index.php?dir=Document/product/Product/ )

    * EasyFolderListingPro can only show 3 files Chinese name while other three file showed with blank filename (http://www.vcasystem.com/index.php/zh-cn/service/download/firmware )

    * I tried every combination of the “UTF-8 options” in EasyFolderListingPro, but still no luck.

    Do you have any idea on this problem?

    Please let me know if you want more information or experiment.

    Thank you.

    #2196

    Michael Gilkes
    Keymaster

    @f1ynnh3. I think we solved this via email. The builtin pathinfo() function was not functioning properly, so I created my own and used it instead. This was solved with the release of version 3.2.11.

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘Can't correctly show Chinese filename’ is closed to new replies.