Michael Gilkes

Home \

Forum Replies Created

Viewing 15 posts - 811 through 825 (of 830 total)
  • Author
    Posts
  • in reply to: Access only for registered users #978
    Michael Gilkes
    Keymaster

    Hi Eric,

    I was thinking… if you really want to not show the empty message, I can show you how to do it by tweaking the easyfolderlistingpro.php file.

    If you have the Joomla 1.5 edition plugin, change { to {/* at lines 666 and 800 and change } to */} at lines 686 and 807.

    If you have the Joomla 1.6 edition plugin, change { to {/* at lines 653 and 787 and change } to */} at lines 673 and 794.

    This should remove the empty message altogether.

    In the next release, I will make this a parameter option. So, you won't have to edit anything.

    Michael Gilkes
    Keymaster

    Hi Eric,

    Thanks for your compliments and questions. For files without file extensions, I am not sure how you would list them, because Jomla's JFolder::files function uses PHP's readdir function to list the files, and it seems as though if readdir finds a file without an extension, it replaces the first character with a dot. That seems to be its standard procedure. I can't change that. I would have to write code to specifically handle that, or maybe even write my own version of JFolder::files to handle it. However, what kind of files are you listing that don't have file extensions? Files available on a web server should have file extensions.

    Honestly, I don't quite understand your second question. If you asking about automatically having the listing expanded, either change Collapse Subfolders to No in the Plugin Manager, or set collapse='0' when you place it in the Article.

    Hope this helps.

    in reply to: Access only for registered users #977
    Michael Gilkes
    Keymaster

    Hi Eric,

    Thanks for using my plugin. You plosted some great questions there. I have the answers to them.

    1. Yes. You can grant access only to registered users by specifying the access level of the article that the plugin is being used in, or you can set the access level for the plugin itself, in the plugin manager. A quick look in your plugin manager, or article manager will reveal the access level setting. If you can't find it, let me know, and I will post a quick how-to.
    2. Unfortunately, there is no way to turn off the empty folder message. Maybe, I can update it in the next release to have that option, but as for right now, there is no option to do that. You might have to be creative in your message, since, at least, you can specify what message you want the user to see in an empty folder.

    Hope this helps.

    Michael Gilkes
    Keymaster

    Hi evn64,

    Thanks for purchasing and using my plugin. From the description you give above, I think the solution may lie in the .htaccess file. However, I am not an expert in editing that. Nonetheless, you may have to give some more information. So far, I understand that you have a folder in your root joomla installation called 'dir', which you specified in your "Location of the Listing Folder". So, your files would be accessed via: http://yoursite.com/dir. Is that correct? But if that is the case, where does '/documenten/' come from?

    By the way, do you have a web address of the page where this is on so that I can see it happening for myself?

    in reply to: EFLPP – Bug Reporting #929
    Michael Gilkes
    Keymaster

    Hi lachie1,

    thanks for purchasing and using my plugin. From reading through your post, it seems like something strange is happening with the slashes. I think you might have typed "mediaSermons_HomeRecent_Sermons" instead of "media/Sermons_Home/Recent_Sermons" in your folder location in the Plugin Managers. So, basically, use forward slashes instead of backslashes.

    If that doesn't solve your problem, then you may have to provide me with two things:

    1. The exact value you have set for "Location of the Listing Folder" in the Plugin Manager.
    2. A link to your website, or rather the specific page that has the listing (so that I can see and examine it for myself)

    I should be able to help you with that information. You can send it to my email address, if you don't want to post it here.

    in reply to: Adding email confirmation to upload form-to myself #971
    Michael Gilkes
    Keymaster

    The email notification feature is available in the Easy Flash Uploader plugin. This feature is not available for the Easy Fil Uploader module.

    in reply to: Setup for non public use #968
    Michael Gilkes
    Keymaster

    All you have to do now, is assign the article to some sort of link, like a menu item in your menu, so that it can be accessible. However, because it has the Special Access Level, it will only be viewable with you log in as the administrator. You can test this by logging in as a normal registered user to see if you see the page. You should only see the page in the menu if you log in as the admin and not as any other registered user.

    Hope this helps.

    in reply to: View of folderlisting #962
    Michael Gilkes
    Keymaster

    Hi wknuvers,

    I had a look at your page. It behaves like it should, except or the indentation. Apparently, the template.css (on line 33) removes the padding for UL tags. This removes the indentation that you normally get to distinguish subolders. You can easily remedy this by editing the styles.css file that is located in plugins -> content -> plg_easyfolderlistingpro_files -> css. Just add the following:

    Code:
    .eflpro_lists ul
    {
        padding-left: 40px !important;
    }

    The !important isn't really necesary, but it ensures that you will override any attempt to alter the padding-left value for ul tags inside of elfpro_lists by any other css script.

    Hope this helps

    in reply to: Setup for non public use #966
    Michael Gilkes
    Keymaster

    Just set the Access Level for the article that you are embedding the plugin in. This can be found on the right hand side under Parameters (Article), and you just have to set it to Special.

    in reply to: How upload txt files #964
    Michael Gilkes
    Keymaster

    Hi VRY6,

    All you have to do is to specify the mime type for the particular type of file you want to upload. Here is a list to reference: http://www.webmaster-toolkit.com/mime-types.shtml

    in reply to: Recent files #963
    Michael Gilkes
    Keymaster

    Hi Buddy,

    Currently, the plugin doesn't really have a feature to show recently added files. Maybe in a later release I can add some time related filters, so that you can specify only files that have been modified within a certain date range (before, and after a certain date). I never thought of that, but it is a good feature to request.

    What I suggest that you do is to post a comment in the Improvement Suggestion topic, explaining how you would want the feature to work. That way, I can easily keep track of it for next release.

    in reply to: View of folderlisting #960
    Michael Gilkes
    Keymaster

    Hi wknuvers,

    Thanks for purchasing and using my plugin. I visited your site, and the plugins acts perfectly normal, as I designed it to act. I don't see a version for list to test it out on your site. I just see the table. Maybe you can place a second instance on the page with the same settings as the table, but instead, specify list as the method. So, it would look something like:

    {easyfolderlistingpro method='list'}

    It should work just like my demo site: http://bit.ly/gmcERV

    in reply to: Override templatebullets and use EFLP's bullets #957
    Michael Gilkes
    Keymaster

    Have you tried to look at the stylesheet for the template? One thing that really helps me with debugging CSS is using Firefox browser with Firebug. Firebug allows you to look at the styles, and see which style is overriding which. It is very useful. I think Chrome has a built-in inspect element feature in the (right-clicked) context menu, but it is not as thorough as Firfox.

    Also, if the listing is publicly available, then you can send me the web address to the page with the listing and I can have a quick look for you if I'm not too busy.

    in reply to: EFUM – Bug Reporting #918
    Michael Gilkes
    Keymaster

    Hi Cheryl,

    Doing the following should fix our problem. Add $mime = strtok($mime, '; '); below both $mime = exec("file -bi '$f'"); (line 160) and $mime = shell_exec("file -bi '$f'"); (line 164).

    This is a minor bug, which will be fixed in the next release. Essentially, some servers add the charset value at the end of the mimetype, and this is what throws off the detection.

    If this doesn't solve it, then it is the case in which the server is not executing the UNIX file command. This usually happens with some shared hosting plans. There is nothing I can do about that. The best thing for you to do in that case is to upgrade your PHP version to 5.3+ so that it can use the fileinfo functions. See http://www.php.net/manual/en/function.finfo-file.php

    Hope this helps. Let me know how it turns out.

    in reply to: EFUM – Bug Reporting #916
    Michael Gilkes
    Keymaster

    Hi cherylanns,

    Thanks for posting to my support site. I am glad you got your server issue sorted out. Now, with your current situation, it is interesting that the error message is "ERROR: The uploaded file type is not permitted". I say this because, the message should be, "ERROR: The uploaded file type, <MIMETYPE>, is not permitted." If the <MIMETYPE> is not in there, that means that the mime type could not be detected.

    This is the result of your system bypassing, or not calling, the fileinfo functions, mime_content_type function, and not executing the file system call. This typcially happens if you are running a Windows PHP server. Is your server OS Windows?

    This link gives a brief explanation: http://www.php.net/manual/en/function.mime-content-type.php#91646

Viewing 15 posts - 811 through 825 (of 830 total)