EFLP inop on Joomla 4.0.3

Home \ forums/topic \ EFLP inop on Joomla 4.0.3

Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #3161
    alweisenborn
    Participant

    I receive this error when try to save a profile:
    An error has occurred.

    0 Joomla\CMS\Form\Field\TextField::validate() rule folderexists missing.

    Call stack
    # Function Location
    1 () JROOT/libraries/src/Form/FormField.php:1236
    2 Joomla\CMS\Form\FormField->validate() JROOT/libraries/src/Form/Form.php:1229
    3 Joomla\CMS\Form\Form->validate() JROOT/libraries/src/MVC/Model/FormModel.php:219
    4 Joomla\CMS\MVC\Model\FormModel->validate() JROOT/libraries/src/MVC/Controller/FormController.php:644
    5 Joomla\CMS\MVC\Controller\FormController->save() JROOT/libraries/src/MVC/Controller/BaseController.php:730
    6 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/libraries/src/Dispatcher/ComponentDispatcher.php:146
    7 Joomla\CMS\Dispatcher\ComponentDispatcher->dispatch() JROOT/libraries/src/Component/ComponentHelper.php:389
    8 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/AdministratorApplication.php:143
    9 Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT/libraries/src/Application/AdministratorApplication.php:186
    10 Joomla\CMS\Application\AdministratorApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:278
    11 Joomla\CMS\Application\CMSApplication->execute() JROOT/administrator/includes/app.php:63
    12 require_once() JROOT/administrator/index.php:32

    Best Regards,

    Al

    #3162
    alweisenborn
    Participant

    Here are the diagnostics for the previous post. The forum bombs out when I try to save them in the same post.

    Temporary Zip Storage Folder: /var/www/alwpdx.ddns.net/tmp
    Zip Storage Folder is Valid?: Yes
    Zip Storage Folder is Writeable?: Yes
    Extensions Details
    Extension Name Enabled Type of Extension Version
    Easy Folder Listing Pro Component Yes component 4.0.1
    Easy Folder Listing Pro Companion Content Plugin Yes content plugin 2.0
    Easy Folder Listing Pro Companion Code Helper Plugin Yes editors-xtd plugin 2.0
    Easy Folder Listing Pro Companion Module Yes module 2.0

    Best Regards,

    Al

    #3163
    alweisenborn
    Participant

    xFirst part of diagnostics
    xJoomla Version: 4.0.3
    xPHP Version: 7.4.25
    xThis is a NON-Windows OS: Linux
    xMIME Detection
    xFILEINFO_MIME_TYPE is defined.
    xfinfo_open is callable.
    xfinfo_file is callable.
    xfinfo_close is callable.
    xmime_content_type is callable.
    xescapeshellarg is callable.
    xexec is callable.
    xshell_exec is callable.
    xMulti-Download Support
    x Zip (.zip) Support: NO
    x GZip (.tar.gz) Support: NO
    x BZip2 (.tar.bz2) Support: Yes

    #3164
    Michael Gilkes
    Keymaster

    @alweisenborn. Thanks so much for posting this error. I just posted version 4.0.2 of Easy Folder Listing Pro, which fixes this. Please update to the latest release. Thanks.

    #3165
    alweisenborn
    Participant

    Hello Michael,

    The problem is fixed. Thank you for the rapid resolution!

    Best Regards,

    Al

    #3166
    mvdhome
    Participant

    Hello Michael, i installed version 4.0.2 of Easy Folder Listing Pro on joomla 4.0.3 and the content part seems to work now, but still get this error when i use the module : Class “ValorApps\Module\EasyFolderListingPro\Site\Helper\EasyFolderListingProHelper” not found

    #3167
    mvdhome
    Participant

    Hello Michael, the error , “ValorApps\Module\EasyFolderListingPro\Site\Helper\EasyFolderListingProHelper” not found seams to be a case sensitive problem. helper is saved as :
    …/administrator/components/com_easyfolderlistingpro/helpers/easyfolderlistingpro.php
    and also the case of the directory’s don’t match, as from the moment that u run this on a linux platform it will fail.

    • This reply was modified 7 months ago by mvdhome.
    • This reply was modified 7 months ago by mvdhome.
    #3170
    Michael Gilkes
    Keymaster

    @mvdhome. Thanks so much for posting. This case sensitivity issue has been really frustrating for me as a developer. I have tested my code on a number of systems: Mac OS X (locally), Windows 10 Pro (locally), and Linux (hosting company), and did not encounter any prior issue before release. I would never knowingly release my code with errors that show up as soon as you click on Dashboard or use the front-end module.

    On top of that, PHP is case-insensitive with regards to namespaces, based on their documentation. Also, PHP developers have known this for years. However, it seems to be related to auto-loading in Joomla. Prior to Joomla 4, this was not an issue.

    Anyways, I will have this fixed for you shortly.

    Thanks so much to you and others who have been reporting this, and even giving some detail and allowing me to access your backend administration. I really appreciate this, as I am unable to replicate these errors on any of the systems available to me.

    What I would appreciate is if persons who encounter this could provide me with a spec detail of their servers so that I can maybe setup a test system to use going forward. Information like your OS details and version/build as well as your PHP versions, Apache (or other web server) details. If I could setup a test system that acts like your environments, then I can catch these errors before releasing my code.

    Thanks so much, everyone.

    #3171
    Michael Gilkes
    Keymaster

    @mvdhome. Ok. I have released version 4.0.3 with the fix to the Module. For your reference, it was not a reference to the Helper that you thought in the administrator backend.

    #3172
    mvdhome
    Participant

    GR8 job Michael, it works now
    brgrds, Marc

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.